WRT54GL als Repeater

Dieser Artikel ist am 05.04.2010 auf vogelzucht-ostenland.de erschienen, wurde nun jedoch auf diese Webpräsenz umgezogen.

Das folgende Tutorial widmet sich der Einrichtung eines WRT54GL als Repeater.

Dabei ist folgendes Szenario gegeben:
Es besteht bereits eine Infrastruktur aus einem WLAN-Router (Hersteller ist nicht vorgegeben), welcher per Ethernet mit einem Modem verbunden ist. Somit verfügt der bestehende Router bereits über eine Verbindung mit dem Internet. Der Router stellt des Weiteren einen WLAN Access Point bereit, wodurch er auch WLAN Geräten in der Nähe den Zugriff auf das Internet ermöglicht. Um nicht jedem den Zugriff auf das WLAN Netz zu gewähren, wird eine WPA Verschlüsselung eingesetzt.

Die Eckdaten vom ersten Router X sind also wie folgt:

  • Modell: egal
  • WAN: per Kabel über Modem bereitgestellt
  • Wlan SSID: WLAN
  • WPA Kennwort: test123

Da unser Client allerdings so weit von dem bestehenden Router entfernt ist, soll ein weiteerr Router als Repeater dienen und das Signal verstärken. Dazu eignet sich mit einigen Modifikationen der WRT54GL. Dieser wird als zusätzlicher Router zwischen dem ersten Router und dem Client platziert. Dabei sei angemerkt, das der Durchsatz unter einer solchen Konstellation leidet, da der WLAN-Verkehr immer zusätzlich über den zweiten Router muss, und dieser zum Senden bzw. Empfangen nur eine Antenne besitzt.

Die Eckdaten vom zweiten Router WRT54GL sind also wie folgt:

  • Modell: WRT54GL (getestet mit v1.1)
  • WAN: von Router 1 bereitgestellt, welcher per WLAN angebunden ist
  • Wlan SSID: 1. WLAN 2. WLAN REPEATER
  • WPA Kennwort: test456

wrt54gl_repeater_szenario

Es folgt eine Schritt für Schritt Anleitung, wie ich das Szenario bei mir zum laufen bekommen habe. Leider kann ich keine Haftung für die Richtigkeit oder eventuell hervorgerufene Schäden an dem Gerät übernehmen. Bei bedenken sollten Sie lieber die Finger von dem Thema lasssen oder einen Fachmann beauftragen.

Firmware herunterladen

Die Firmware lässt sich unter folgender URL herunterladen. Es gibt allerdings noch etliche anderweitig angepasste Images. Das von mir verwendete ist ein auf openwrt aufbauendes mit dem webinterface x-wrt.
http://downloads.x-wrt.org/xwrt/kamikaze/7.09/brcm-2.4/openwrt-wrt54g-2.4-squashfs.bin

Firmware flashen

  • PC per Ethernet an den Router anschließen und dieser Schnittstelle die IP 192.168.1.2 geben
  • den folgenden Befehl in der Shell ausführen (Voraussetzung ist ein Linux Betriebsystem mit installiertem tftp)
  • echo -e "binary\nrexmt 1\ntimeout 60\ntrace\nput openwrt-wrt54g-2.4-squashfs.bin\n" | tftp 192.168.1.1
  • erst jetzt den Router mit Storm versorgen, dann wird diesem, während der Router bootet, die neue Firmware per tftp untergeschoben
  • Nach dem flashen muss der Router noch neu booten, dies ist abgeschlossen, wenn die DMZ LED nicht mehr leuchtet.

Firmware flashen

  • PC per Ethernet an den Router anschließen und dieser Schnittstelle die IP 192.168.1.2 geben
  • den folgenden Befehl in der Shell ausführen (Voraussetzung ist ein Linux Betriebsystem mit installiertem tftp)
  • echo -e "binary\nrexmt 1\ntimeout 60\ntrace\nput openwrt-wrt54g-2.4-squashfs.bin\n" | tftp 192.168.1.1
  • erst jetzt den Router mit Storm versorgen, dann wird diesem, während der Router bootet, die neue Firmware per tftp untergeschoben
  • nach dem flashen muss der Router noch neu booten, dies ist abgeschlossen, wenn die DMZ LED nicht mehr leuchtet

Telnet

  • telnet 192.168.1.1
  • in dieser Telnetsitzung sollten sie nun das Passwort für den Router ändern, dies wird abgefragt nach der eingabe von passwd
  • nun ist es auch möglich sich anstatt über telnet über das sichere ssh zu verbinden durch folgenden Befehl ssh root@192.168.1.1

Anpassen von /etc/config/wireless

  • Das anpassen kann durch den vi vorgenommen werden, welcher hier allerdings nicht erläutert werden soll, ziehen Sie bitte dazu eine der vielen Guten Linuxreferenzen zu rate.

config wifi-device wl0
option type broadcom
option channel 5
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid WLAN_REPEATER #SSID für das WLAN mit dem verstärkten Signal (anpassen)
option hidden 0
option encryption psk #Verschlüsselung des verstärkten Signals, in diesem Fall WPA (anpassen)
option key test456 #Schlüssel des verstärkten Signals (anpassen)
option isolate 0
option bgscan 0
option wds 0
config wifi-iface
option device wl0
option mode sta
option ssid WLAN #SSID für das WLAN welches verstärkt werden soll (anpassen)
option encryption psk #Verschlüsselung vom WLAN welches verstärkt werden soll, in diesem Fall WPA (anpassen)
option key test123 #Schlüssel des zu verstärkenden Signals (anpassen)
option network wan
option hidden 0
option isolate 0
option bgscan 0
option wds 0

Anpassen von /etc/config/network

  • Das anpassen kann durch den vi vorgenommen werden, welcher hier allerdings nicht erläutert werden soll, ziehen Sie bitte dazu eine der vielen Guten Linuxreferenzen zu rate.

#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.2.1 #IP von Router2, d.h. diese IP wird im Repeater Netz verwendet, Sie darf nicht mit dem Netz von Router 1 übereinstimmen, gegebenenfalls anpassen
option netmask 255.255.255.0 #Subnetzmaske, gegebenenfalls anpassen
option gateway '192.168.1.1' #IP von Router1 welcher mit dem Internet verbunden ist (anpassen)
option dns '192.168.1.1' #IP von Router1 welcher mit dem Internet verbunden ist (anpassen)
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp

Fertig

Nachdem die Konfigurationdateien erfolgreich editiert wurden, können Sie mit reboot einen Neustart veranlassen, danach werden auch die neuen Konfigurationdateien eingelesen und der Router sollte seine neue Funktion erfüllen. Falls Sie sich nun wieder mit dem Router verbinden wollen müssen Sie bedenken, dass wir durch die Konfiguration die IP-Adresse des Router verändert haben. Es gilt ab nun die neue, in unserem Beispiel 192.168.2.1. Das Webinterface lässt sich überigens über Eingabe dieser IP im Browser erreichen.

Es folgt eine Schritt für Schritt Anleitung, wie ich das Szenario bei mir zum laufen bekommen habe. Leider kann ich keine Haftung für die Richtigkeit oder eventuell hervorgerufene Schäden an dem Gerät übernehmen. Bei bedenken sollten Sie lieber die Finger von dem Thema lasssen oder einen Fachmann beauftragen.

Firmware herunterladen

Die Firmware lässt sich unter folgender URL herunterladen. Es gibt allerdings noch etliche anderweitig angepasste Images. Das von mir verwendete ist ein auf openwrt aufbauendes mit dem webinterface x-wrt.
http://downloads.x-wrt.org/xwrt/kamikaze/7.09/brcm-2.4/openwrt-wrt54g-2.4-squashfs.bin

Firmware flashen

  • PC per Ethernet an den Router anschließen und dieser Schnittstelle die IP 192.168.1.2 geben
  • den folgenden Befehl in der Shell ausführen (Voraussetzung ist ein Linux Betriebsystem mit installiertem tftp)
  • echo -e "binary\nrexmt 1\ntimeout 60\ntrace\nput openwrt-wrt54g-2.4-squashfs.bin\n" | tftp 192.168.1.1
  • erst jetzt den Router mit Storm versorgen, dann wird diesem, während der Router bootet, die neue Firmware per tftp untergeschoben
  • Nach dem flashen muss der Router noch neu booten, dies ist abgeschlossen, wenn die DMZ LED nicht mehr leuchtet.

2 Gedanken zu „WRT54GL als Repeater

  1. Bin zufällig über Deine Seite gestolpert, auf der Suche nach einer besseren Doku als dem Chaos bei OpenWRT.org – und, tausend Dank!!
    Deine Anleitung ist straight-forward und das Ergebnis macht genau das was es soll. Allerdings mit dem propreitären Broadcomm-Treiber 2.4, mit dem offenen Treiber aus dem aktuellen Trunk hab ichs nicht hinbekommen, aber egal…
    Super Anleitung, solltest Du mal nach OpenWRT verlinken!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.